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Abstract 
 

  
These Application Notes describe the configuration steps required for the iVoice Speech-
Enabled Auto Attendant to successfully interoperate with the Avaya IP Office System.  
Features and functionality were validated and performance testing was conducted in order to 
verify operation under load. Information in these Application Notes has been obtained through 
interoperability compliance testing and additional technical discussions.  Testing was 
conducted via the DeveloperConnection Program at the Avaya Solution and Interoperability 
Test Lab.  
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1. Introduction 
These Application Notes describe the compliance-tested configuration utilizing Avaya IP Office 
1.4 and iVoice Speech-Enabled Auto Attendant 3.2. 
 
The iVoice Speech-Enabled Auto Attendant (SE-AA) is a stand-alone auto attendant that enables 
businesses to incorporate speech recognition into their current communication systems without 
duplicating voice mail applications.  Features provided by SE-AA include: 
 

• Recognizing any name or word in the English language 
• Allowing callers to barge-in1 on the Auto Attendant at any time 
• GUI-Configurable User/Extension Dictionary 

 
The SE-AA interfaces with the IP Office System over the LAN via TAPI (IP Office TAPI and 
Wave drivers are installed on the SE-AA server).  The IP Office is configured to route inbound 
calls to a hunt group that includes “virtual” TAPI Wave extensions which are enabled on the SE-
AA.  Upon receipt of the inbound calls, the SE-AA determines the destination extension via 
caller voice recognition or DTMF digits entered.  The SE-AA then transfers the call to the 
destination extension by performing a TAPI-based transfer.   The SE-AA is not a voice mail 
system.    
 
Upon initial configuration, the SE-AA goes through a tuning period where it adapts to the speech 
levels, noise levels, and line clarity of the phone system it is using.  After the initial tuning 
period, the success rate for recognizing names increases.  The SE-AA has the ability to speed up 
tuning, but this requires experienced SE-AA operators and is not left to the end-user to 
configure.  After three failed attempts by the caller, the SE-AA will route the call to the 
Operator.  Please refer to the SE-AA product documentation or contact iVoice technical support 
for more information.  
 
The tested configuration is shown in Figure 1. 

                                                 
1 Use of iVoice barge-in feature is recommended for IP Office systems configured with only T1 / PRI trunks and no 
analog stations.  Please refer to section 1.1 for details. 
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Figure 1: iVoice SE-AA and Avaya IP Office Configuration 

 

1.1. Compliance Test Notes / Observations 
IVoice Barge-In feature limited to IP Office configurations using only T1/PRI trunks and 
no analog stations:  The current version of the IP Office TAPI Wave driver does not separate 
incoming and outgoing audio streams on analog devices (trunk and station).  It is recommended 
that barge-in be disabled on SE-AA TAPI Wave systems connected to IP Office systems 
configured with analog trunks and/or analog stations.   IP Office configurations using T1/PRI 
trunks only and no analog stations are unaffected. 
 
Recorded Greeting-Clipping Observation:  Either beginning or ending portions of greetings 
recorded on the SE-AA get clipped on playback.  Users are advised to pause for 1-2 seconds 
prior to recording a greeting.  IVoice is investigating clipping of the beginning and end portion 
of greetings. 
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2. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 
 

Equipment Software 
Avaya IP 403 Office System 1.4(25) 
Avaya IP 400 Phone 30 Expansion Module - 
Avaya 6408D+, 6416D+M Telephones - 
Avaya 4612 IP Telephones 1.73 
iVoice Speech-Enabled Auto Attendant  3.2 
Generic PCs  Windows 2000 Professional 
Generic Analog Telephones - 

 

3. Configure Avaya IP Office 
These Application Notes address provisioning of the IP Office as it relates to integration of the 
TAPI SE-AA.  For all other provisioning information such as provisioning of the trunks for 
outbound dialing, call coverage, extensions, etc., please refer to the IP Office Product 
documentation. 
 

Note 1: The SE-AA does not support mixed extension lengths but it does support existing 
extensions with the same length.  For example, the SE-AA does not support all the extensions of 

a switch configured with 3-digit and 4-digit extensions. The reader is advised to take this 
limitation into account during provisioning with the SE-AA and ensure the switch is configured 

with extensions of the same length. 
 

Step Description 
 IP Office License Key Physical Installation 
1.  Plug in the red Avaya Software Sentinel key into the parallel port of the IP Office Manager 

PC. 
 Configure License Key Server IP Address 
2.  Log in to the IP Office Manager PC and go to Start → Programs → IP Office → 

Manager to launch the Manager application. Login to the Manager application using the 
appropriate credentials. 

3.  In the Manager window that appears, select File → Open to search for the IP Office 
system in the network. 

4.  Log in to the IP Office system using the appropriate login credentials to receive its 
configuration. 
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Step Description 
5.  In the Manager window, go to the Configuration Tree and double-click System.  In the 

System Configuration window that appears, select the System tab and set License Server 
IP Address to the IP address of the machine to which the red Avaya Software Sentinel key 
is connected.  This is typically the IP Office Manager PC. 
 

 
 

 Install Licenses 
6.  In the Manager window, go to the Configuration Tree and double-click License to open 

the list of licenses installed in the IP Office system.   
7.  Right click in the license list window and select New. In the License window that appears, 

enter the CTI Link Pro License Key and click OK. 
 

 
8.  Repeat Step 7 to install the TAPI WAVE USER license. 
9.  In the Manager window, select File → Save to save the licenses to the IP Office system 

and wait for the system to update. 
 
Note 2:  Before the system reloads, the new licenses will be listed with an Unknown status.  
After the system reloads, the new licenses will list as Valid. 

 Configure TAPI Extensions 
10.  In the Manager window, select File → Open to search for the IP Office system in the 

network. 
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Step Description 
11.  Log in to the IP Office system using the appropriate login credentials to receive its 

configuration. 
12.  In the Manager window, go to the Configuration Tree and double-click User to open the 

list of users on the IP Office system. 
13.  Right click in the User list window and select New.  In the User window that appears, set 

Name to TAPI:x where x is the number of the TAPI user extension desired, e.g., 1, 2, etc., 
and Extension to the extension number to be used.  
 

 
Note 3:  Although the SE-AA requires end-user extensions to be uniform in length, the 
length of the TAPI Wave User extensions are not an issue because the TAPI Wave User 
extensions are not listed in the SE-AA User Directory. 
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Step Description 
14.  In the Voicemail tab of the User window, verify Voicemail On and Voicemail Ringback is 

not checked. 
 

 
Note 4: This applies only to the TAPI Wave extensions and is not relevant whether the 
system has voicemail or not. 

15.  In the Telephony tab of the User window, verify Call Waiting On is unchecked, check 
Offhook Station and click OK. 
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Step Description 
16.  In the Manager popup that appears, click No. 

 

 
17.  Repeat Steps 13 - 16 for each TAPI extension needed. For the purposes of these 

Application Notes, four TAPI extensions were created (extensions 101 – 104).  The 
number of iVoice licenses and Avaya TAPI Wave licenses purchased limits the number of 
TAPI extensions that can be created. 

 Configure Hunt Group 
18.  In the Manager window, go to the Configuration Tree and double-click HuntGroup to 

open the list of hunt groups on the IP Office system. 
19.  Select the Main hunt group by double-clicking. 
20.  In the HuntGroup window that appears, add extensions to the Extension List that will be 

part of the hunt group by right clicking in the Extension List section and selecting Add.  
Then, set Extension to 200 (or the extension number desired for the hunt group), Hunt Type 
to Circular, and Call Waiting On to unchecked. 
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Step Description 
21.  In the Voicemail tab of the HuntGroup window, verify Voicemail On is not checked. 
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Step Description 
22.  In the Queuing tab of the HuntGroup window, verify Queuing On is not checked and click 

OK. 
 

 
Note 5: Hunt Group queuing to TAPI Wave extensions is not supported in this release of 
IP Office. 

23.  In the Manager window, select File → Save to save the configuration to the IP Office 
system and wait for the unit to reboot with the saved configuration. 

24.  Log in to the IP Office system using the appropriate login credentials to receive its 
configuration. 

 Select Inbound Call Route 
25.  In the Manager window, go to the Configuration Tree and double-click Incoming Call 

Route to open the list of incoming call routes on the IP Office system.  Select the route 
with the destination set to Main and double-click it. 



 
SCR; Reviewed: 
NAB 01/21/04 

Solution & Interoperability Test Lab Application Notes 
©2004 Avaya Inc. All Rights Reserved. 

11 of 26 
ivoice-ipotapi.doc 

 

Step Description 
26.  In the Incoming Call Route window that appears, record the Line group ID.  Click OK. 

 

 
 

 Assign Trunks to the Incoming Call Route 
27.  In the Manager window, go to the Configuration Tree and double-click Line to open the 

list of lines (trunks) available on the IP Office system.  Double-click the Line (analog or 
digital) whose incoming calls are to be routed to the SE-AA. 

28.  In the Line window that appears, assign the line to the Line group ID recorded in Step 26.   
 

 
For example, each channel in the PRI line window must be assigned to the Line group ID 
recorded in Step 26.  To do so, double-click the channel and edit the Incoming Group field 
in the Edit Channel pop up that appears. A similar procedure is used on the analog lines. 
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Step Description 
29.  In the Manager window, select File → Save to push the configuration to the IP Office 

system and wait for the unit to reboot. 
30.  Verify the incoming call route is properly operating by temporarily assigning a telephone 

extension to the hunt group and placing calls through the selected inbound line (trunk) 
until the telephone extension assigned to the hunt group rings -- the TAPI Wave extensions 
will not answer until after the SE-AA is configured.  

31.  Repeat Steps 26 – 28 for each line (trunk) assigned to the incoming call route. 
 

4. Configure the iVoice Speech-Enabled Auto Attendant 
These Application Notes address provisioning of the iVoice Speech-Enabled Auto Attendant as 
it relates to TAPI integration with the Avaya IP Office System.  For all other provisioning 
information, such as iVoice Speech-Enabled Auto Attendant software installation, License Key 
installation and Speech Recognition engine tuning, please refer to the Speech-Enabled Auto 
Attendant System Guide available on the iVoice Software Installation CD. 

4.1. Installing and Configuring Avaya IP Office TAPI Service Provider 
Please refer to the Avaya IP Office CTI Link Installation Manual, 40DHB0002UKCC – Issue 4 
(05/08/2002) for additional information. 
 

Step Description 
1.  Install the Avaya IP Office TAPI Service Provider driver on the SE-AA server from the 

Avaya IP Office User Applications CD.  NOTE: Do not install the Phone Manager. 
2.  After the system reboots, log in to the system again as administrator and go to Start → 

Settings → Control Panel.  In the Control Panel window that appears, double-click 
Phone and Modem Options. 

3.  In the Advanced tab of the Phone and Modem Options window, double-click Avaya IP 
Office TAPI2 Service Provider. 
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Step Description 
4.  In the Avaya TAPI2 configuration window that appears, set Switch IP Address to the IP 

Address of the IP Office System, check Third Party, set Switch Password to the IP Office 
System password, check WAV Users, and click OK. 
 

 
5.  Reboot the system. 

 Verify Connectivity with the IP Office 
6.  After the system reboots, log in to the system and go to Start → Programs → 

Accessories → Communications → Phone Dialer. 
7.  In the Phone Dialer window that appears, select Edit → Options. 
8.  In the Lines tab of the Options window that appears, select the Phone Calls: drop-down 

list.  If one or more “IP Office Phone: XXX” (where XXX is an extension number) entries 
appear, then the IP Office TAPI Driver is installed and working properly. 

 

4.2. Installing and Configuring Avaya IP Office TAPI Wave Driver 
The IP400 wave driver is a soft emulation; there is no associated hardware.  It therefore needs to 
be installed manually. 
 
The steps that follow are for a Windows 2000 installation; please refer to the Avaya IP Office 
CTI Link Installation Manual, 40DHB0002UKCC – Issue 4 (05/08/2002) for additional 
information as well as the Windows 2000 and NT installation steps. 
 

Step Description 
 Install TAPI Wave Driver 

1.  Log in to the SE-AA server as administrator and go to Start → Settings → Control 
Panel.  In the Control Panel window that appears, double-click Add/Remove Hardware. 

2.  In the Add/Remove Hardware Wizard Welcome window that appears, click Next. 
3.  In the Choose a Hardware Task window that appears, select ‘Add/Troubleshoot a device’ 

and click Next. 
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Step Description 
4.  In the New Hardware Detection window that appears, wait while the PC searches for a new 

device. 
5.  In the Choose a Hardware Device window, select ‘Add a new device’ and click Next. 
6.  In the Find New Hardware window, select ‘No, I want to select the hardware from a list’ 

and click Next. 
7.  In the Hardware Type window that appears, select ‘Sound, video and game controllers’ 

and click Next. 
8.  In the Select a Device Driver window that appears, click Have Disk…. 
9.  In the Install from Disk popup that appears, click Browse… to navigate to the Wave32 

directory on the Avaya IP Office User Applications CD, select the oemsetup.inf file, and 
click Open. 

10.  In the Install From Disk popup that appears, verify the pull-down field lists the path to the 
Wave32 directory on the CD and click OK. 

11.  In the Select a Device Driver window that appears, verify Avaya IP400 WIDWOD driver is 
listed in the Models field and click Next. 

12.  In the Start Hardware Installation window that appears, click Next. 
13.  In the Completing the Add/Remove Hardware Wizard window that appears, click Finish. 
14.  In the Systems Settings Change popup that appears, click Yes to reboot the system. 

 Ensure Avaya TAPI Wave Driver is only used by TAPI  
15.  Login to the SE-AA server as administrator and go to Start → Settings → Control Panel.  

In the Control Panel window that appears, double-click Sounds and Multimedia 
Properties. 

16.  In the Hardware tab of the Sounds and Multimedia Properties window, double-click Avaya 
IP400 WIDWOD driver. 
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Step Description 
17.  In the Avaya IP400 WIDWOD driver Properties window that appears, go to the 

Properties tab. 
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Step Description 
18.  In the Properties tab of the Avaya IP400 WIDWOD driver Properties window, double-

click Audio Devices to reveal the Avaya IP400 WIDWOD driver and double-click Avaya 
IP400 WIDWOD driver. 

 
 

19.  In the Avaya IP400 WIDWOD driver Properties window that appears, check Do not map 
through this device and click OK. 
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Step Description 
20.  In the Changes Saved popup that appears, click OK and reboot the SE-AA server so the 

changes can take effect. 
 

 
 

4.3. Configuring the iVoice Speech-Enabled Auto Attendant 
 

Step Description 
 Enable incoming TAPI lines 

1.  Log in to the SE-AA server and go to Start → Programs → iVoice.com → iVoice Media 
Center to launch the Media Center. 

2.  In the iVoice Media Center window that appears, select Settings → Tapi Line Selection. 
3.  In the TAPI Extension Chooser window that appears, select all TAPI extension numbers 

that will be enabled as incoming TAPI lines to the SE-AA server and move them to the 
left-side of the window by clicking “<<”.  In this example, IP Office Phone: 101 through 
104 have been selected.  When finished, click OK. 
 

 
4.  Close and restart the SE-AA media center program for the changes to take effect. 
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Step Description 
 Settings 

5.  Log in to the SE-AA server and go to Start → Programs → iVoice.com → iVoice Media 
Center to launch the Media Center. 
 

 
6.  In the iVoice Media Center window that appears, select Auto Attendant → Settings. 
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Step Description 
7.  In the Settings window that appears, select the Miscellaneous tab and enter the desired 

times for playing day and night prompts. 
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Step Description 
8.  In the Settings window, select the Extensions tab and set Extension Digits (length of the 

extensions on the switch) to 4, Administrator Extension to 4444, Supervisor Extension to 
3333, Password (user-defined), Operator Extension Day (extension to which the SE-AA 
routes calls after three failed call attempts) to 1000 and Operator Extension Night to 1000. 
 
Click OK. 
 

 
Note 6:  The SE-AA does not support mixed extension lengths but it does support existing 
extensions with the same length.  For example, the SE-AA does not support all the 
extensions of a switch configured with 3-digit and 4-digit extensions. The reader is advised 
to take this limitation into account during provisioning with the SE-AA and ensure the 
switch is configured with extensions of the same length. 

 Recording Prompts 
9.  Place a call to the hunt group from an extension on the IP Office system.  When the 

welcome greeting plays, dial the supervisor extension, e.g., 3333, and enter the supervisor 
password when prompted. 

10.  To record the day greeting, press 1.  Press 2 to record the night greeting.  For both the day 
and night greeting, press 1 to record, 2 to review the recording, or # to exit. 

11.  Hang up when finished. 
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4.4. Configuring the Telephone Directory in the iVoice SE-AA 
 

Step Description 
 Adding Names to the Telephone Directory 

1.  In the iVoice Media Center window, select Auto Attendant → Telephone Directory. 
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Step Description 
2.  In the Telephone Directory window, click on the Add Row button at the bottom of the 

window to add a blank row to the Directory.  Enter the appropriate information in the 
blank row.  The password will default to the extension number if not entered.  Click 
Apply. 
 

 
If the name is in the dictionary, it will be saved in the Telephone Directory.  If it is not in 
the dictionary, a Media Center message box will pop up.  Click OK. 
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Step Description 
3.  If the name is not in the dictionary, return to the Telephone Directory window and click 

More>>.  The Telephony Directory window expands to show the Dictionary entry form on 
the right with the word that is not in the dictionary as well as a generated pronunciation for 
it. Click Add Name to add it to the dictionary.   
 

 
If the name is added successfully to the dictionary, the following message pop up will 
appear.  Click OK. 
 

 
 

4.  Return to the Telephone Directory window and click Apply to save the entry into the 
Telephone Directory. 

5.  Repeat Steps 2 - 4 for all names that need to be added to the dictionary.  When done, click 
OK. 
 
Note 7:  iVoice has tools available to import a large quantity of names and extensions.  
Please refer to the product documentation to learn how to do this. 

 Recording Names 
 The SE-AA system will pronounce a person’s name based on the dictionary entry defined 

for the name.  Users have the option of recording their names for the SE-AA system to use 
instead. 

6.  Dial the SE-AA hunt group extension from an extension on the IP office system.  When 



 
SCR; Reviewed: 
NAB 01/21/04 

Solution & Interoperability Test Lab Application Notes 
©2004 Avaya Inc. All Rights Reserved. 

24 of 26 
ivoice-ipotapi.doc 

 

Step Description 
connected to the SE-AA, dial the Administrator Extension, e.g., 4444. 

7.  When prompted, dial the extension of the name you will be recording. 
8.  Press 1 to record the name, 2 to review the recording, or # to exit. 
9.  You may only record 1 name at a time.  Repeat Steps 6 - 8 to record more names. 

 

5. Interoperability Compliance Testing 
This Interoperability Compliance Test included feature, functionality and performance load 
testing.  Feature and functionality testing examined the SE-AA’s ability to properly transfer 
inbound and internal calls to the appropriate destination extension (digital, analog, IP phone) 
regardless of whether the caller used voice or DTMF input.  Performance load tests verified the 
configuration to continue operating under load.  

5.1. General Test Approach 
Feature and functionality testing was performed manually.  Inbound calls were made to the IP 
Office system from analog, T1 and PRI trunks as well as internal extensions.  The IP Office 
system routed the calls to the SE-AA, which transferred the calls based on speech recognition, or 
DTMF input of a valid extension number on the IP Office system.  Analog loop start trunks from 
the central office were connected to the IP Office.  T1 trunk connectivity to the central office was 
simulated during testing by connecting the T1 port on the IP Office to an Avaya Communication 
Manager system.  The configuration was changed to PRI on both systems for the PRI test cases.   
 
Performance testing was accomplished by utilizing call generation tools for placing and 
receiving calls from T1 to analog station ports.  Analog station ports on the call generation tool 
were connected to analog station ports on the IP Office Phone Expansion Module of the IP 
Office system.  Call generation tool scripts were written to place calls to the SE-AA configured 
hunt group on the IP Office system.  Each script barged in on the Welcome greeting and spoke a 
different name or department.  The SE-AA then transferred the calls to the appropriate 
destination extension.  The call generation tool script on the destination extension verified the 
incoming call was from the proper source.   

5.2. Test Results 
All feature, functionality, and performance test cases passed successfully.  Overnight 
performance testing at a rate of approximately 525 - 535 BHCC was conducted on the SE-AA 
system provided for compliance testing.  The SE-AA was provisioned with four (4) TAPI Wave 
extensions.  Performance statistics were captured on the SE-AA server to ensure that it was able 
to handle the call volume. 

6. Verification Steps 
The following steps can be used to verify system operation after a field installation: 
 
� To verify the SE-AA is operating properly for internal calls:  place a call to the SE-AA 

hunt group from an IP Office extension.  Verify the SE-AA Welcome greeting plays and 
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either speak a name or department, or enter a valid extension number on the IP Office 
system.  Verify the call is transferred to the correct extension. 

� To verify the SE-AA is operating properly for external calls:  place a call to the IP Office 
system through one of the trunks assigned to the SE-AA hunt group.  Verify the SE-AA 
Welcome greeting plays and either speak a name or department, or enter a valid 
extension number on the IP Office system.  Verify the call is transferred to the correct 
extension. 

7. Support 
Customers should call the iVoice Customer Service Center when having problems related to the 
Speech-Enabled Auto Attendant.  iVoice will then determine the nature of the problem and 
recommend the best plan to the customer whether it is to: 
� Fix the problem through remote access. 
� Dispatch, at iVoice’s discretion, on-site technical support. 

 
For technical support on Speech-Enabled Auto Attendant, contact the iVoice Customer Service 
Center at (732) 441-7700 and dial x217 or say “Tech Support”.  Technical support email can be 
sent to techsupport@ivoice.com.  

8. Conclusion 
These Application Notes describe the required configuration steps for iVoice’s Speech-Enabled 
Auto Attendant to successfully interoperate with Avaya IP Office System.  Features, 
functionality, and performance were validated.  The SE-AA speech recognition engine goes 
through an initial tuning period where the system adapts to the speech levels, noise levels, and 
line clarity of the phone system it is using.  Adaptation allows the system to accurately identify 
call recipients through speech.   
 
The SE-AA does not support mixed extension lengths but it does support existing extensions 
with the same length.  For example, the SE-AA does not support all the extensions of a switch 
configured with 3-digit and 4-digit extensions. The reader is advised to take this limitation into 
account during provisioning with the SE-AA and ensure the switch is configured with extensions 
of the same length. 

9. Additional References  
Avaya IP Office CTI Link Installation Manual, 40DHB0002UKCC – Issue 4 (05/08/2002). 
 
Avaya IP Office Installation Manual, 40DHB0002USCL, Issue 8 (03/07/2003). 
 
iVoice Speech-Enabled Auto Attendant System Guide, Version 3.1.0. 
 



 
SCR; Reviewed: 
NAB 01/21/04 

Solution & Interoperability Test Lab Application Notes 
©2004 Avaya Inc. All Rights Reserved. 

26 of 26 
ivoice-ipotapi.doc 

 

 
 
©2004 Avaya Inc. All Rights Reserved. 
Avaya and the Avaya Logo are trademarks of Avaya Inc.  All trademarks identified by ® and ™ 
are registered trademarks or trademarks, respectively, of Avaya Inc.  All other trademarks are the 
property of their respective owners.  The information provided in these Application Notes is 
subject to change without notice.  The configurations, technical data, and recommendations 
provided in these Application Notes are believed to be accurate and dependable, but are 
presented without express or implied warranty.  Users are responsible for their application of any 
products specified in these Application Notes. 
 
Please e-mail any questions or comments pertaining to these Application Notes along with the 
full title name and filename, located in the lower right corner, directly to the Avaya 
DeveloperConnection Program at devconnect@avaya.com.  
 
 

 
 


